Arctic Cat Prowler Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
222 Posts
Discussion Starter #1
2010 H1 700 efi xtx with only 320 kilometres on it
when i start the cat it mumbles for 5 seconds then idles normaly and when it is minus 5°celcius it will fire up stalls right away and on the second start it is ok

i will call my dealer about it but was wondering if someone knows about this problem and if can be adjusted cause my dealer has been operating for about 8 months only and sometimes experience is not there
 

·
Registered
Joined
·
421 Posts
2010 H1 700 efi xtx with only 320 kilometres on it
when i start the cat it mumbles for 5 seconds then idles normaly and when it is minus 5°celcius it will fire up stalls right away and on the second start it is ok

i will call my dealer about it but was wondering if someone knows about this problem and if can be adjusted cause my dealer has been operating for about 8 months only and sometimes experience is not there
the simptoms say either lean from possible low fuel pressure or check valve not holding fuel in the lines,something along those lines. or possible coolant sensor error,telling the ecm the eng/air temp is warmer then it really is,so the ecm is not enrichining enuf for cold start. does it start better during warm weather?
 

·
Registered
Joined
·
222 Posts
Discussion Starter #4
if the motor is hot it is ok , the first time i start it when it he is cold even by hot temp it will mumble and it happen twice that it stalled and once it was not even below zero
and my buddys 09 700 is the same
 
1 - 4 of 4 Posts
Top