Arctic Cat Prowler Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
hi everyone,when i drive on ruff gravel roads i get a bad noise that viabreats throw my mechine.it is hard to explain but sounds like the front is going to fall apart. tooked it to the dealer they cant figure it out but i got to find it because iam getting scared to drive it because something could let go,,,have anyone got any ideas what it could be.
 

·
Registered
Joined
·
271 Posts
is there any way you can take the engine cover off and run it for a minute to see if the engine motor mounts are secure, i have seen the H1 motor mounts wear out and the motor bounce around and torque side to side violently. also when the mounts let go, the drivers side of the motor will actually rub the frame rail. it could be your motor hitting the frame rail. just a thought? driving it and watching the motor will show you if it is moving too much
 

·
Registered
Joined
·
32 Posts
Discussion Starter #3
tryed what you said,the mounts seem to be allright,it is hard to explain what its like.....a tumping noise the same that would be in a car if the struts we gone?:confused:
 

·
Registered
Joined
·
618 Posts
Some more info would be helpful, what year, what machine, mileage, tire size, etc.

You don't by chance have items in the front underhood storage box that would be bouncing around do you?
 

·
Registered
Joined
·
155 Posts
check your rack and pinion, i had to tighten the bolts on mine once. one bolt was out 5-6 turns. just a thought!
 

·
Registered
Joined
·
421 Posts
tryed what you said,the mounts seem to be allright,it is hard to explain what its like.....a tumping noise the same that would be in a car if the struts we gone?:confused:
look at your shock bushings where the shocks bolt to arms and frame,these bushings are junk and beat out in no time,you`l see the rubber squeezed out.then the steel sleeve hits metal on metal to the shock eye.also ckeck the ball joints for looseness if veh has alot of miles or spends alot of time in water.
 

·
Registered
Joined
·
15 Posts
I had a bad embarrassing rattle on mine that turned out to be the slide in trailer hitch. It would rattle like crazy when under load. I ended wrapping the hitch with electical tape before sliding it back in all is quiet now.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #11
it is a 2010 xtx with 720 miles on it, factory tires,had trouble at the begining with the front def. popping out of def had it to the dearler sevweal times ,fixed now with the o-rings the noise started after i had it to the dealer the second time its getting so bad iam afraid to drive it becauce it could cause a crash
 

·
Registered
Joined
·
421 Posts
it is a 2010 xtx with 720 miles on it, factory tires,had trouble at the begining with the front def. Popping out of def had it to the dearler sevweal times ,fixed now with the o-rings the noise started after i had it to the dealer the second time its getting so bad iam afraid to drive it becauce it could cause a crash
they would have had the shock and ball joint bolts out,check there for looseness
 

·
Registered
Joined
·
32 Posts
Discussion Starter #13
checked .seems like the balljoint on the right sidde got some give in it when i put my hand on the tire and shake the machine you can feel the tire tumping like if the nuts on the rim was loose but i checked them and they are tight.
 
1 - 14 of 14 Posts
Top