Arctic Cat Prowler Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I'm new to the site and just wanted to say hi. I'm from Louisiana and have only had my prowler about 2 months but so far I've loved it. My kids also love it cause we now go to the river everyday!
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Thanks, and your right this is a great site with lots of info! I have a 09 650 xt it had 580 miles and about 80hrs when I got and now it has 1100 miles LoL we have rode it everyday that we could! It is in great shape. It was female owned before us and I was told it wasn't put in the mud and was only used to carry drinks for other riders. I haven't had any problems yet but I just started to notice something that may become a problem. When I turn hard to the left or right it pops in the front end. Sounds like a wheel bearing but I jacked it up and I can't find any slack. Anyway other than that I can't get enough of it. Im going to try to post a pic.
 

·
Registered
Joined
·
2,681 Posts
Welcome, Check your Ball Joints and control arm pivot bolts torque 33Ftlbs
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Thanks Joe I'll ck that. Is it the bolts where the upper and lower A arms bolt to the knuckle or where they bolt to the frame? I think I know which ones your talking about, they don't have nuts and they hold the upper and lower ball joints in place. It just pops once then it don't do it again till you turn the steering the other way and it has to be moving for some reason.
 

·
Registered
Joined
·
2,681 Posts
Thanks Joe I'll ck that. Is it the bolts where the upper and lower A arms bolt to the knuckle or where they bolt to the frame? I think I know which ones your talking about, they don't have nuts and they hold the upper and lower ball joints in place. It just pops once then it don't do it again till you turn the steering the other way and it has to be moving for some reason.
I would also check the pinch bolts on the steering knuckle for the ball joints ths factory torque spec isnt tight enougn and the ball joint pin moves and ruins the treads on the bolt I replaced my pinch bolts and torqued them to 45Ftlbs and have had no more problems with them.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
I think I found my problem, I jacked it up and both sides have a little slack in the bottom ball joint. I tightened the pinch bolts but still had slack so I'm going to order some ball joints. I'm surprised that they wore so quickly, It has 28" swamplites. Is that too big a tire? Thanks for the help.
 
1 - 10 of 10 Posts
Top