Arctic Cat Prowler Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
hello all,

figured i had better say hi before i start searching hi and lo for help with my bike......also where exactly would i do that? my 08 prowler 650 will not start, took it out on the weekend and we rode HARD, on the last day i was pushing some bush and she just up and died on me,started and ran long enough to get it on the trailer but was running really rough and now has not started since. there is fuel at the carb, and good spark and is turning over as usual, does anyone have any ideas or insight on how to fix this? any insight would be appreciated.

Thanks

Chris
 

·
Registered
Joined
·
733 Posts
hello all,

figured i had better say hi before i start searching hi and lo for help with my bike......also where exactly would i do that? my 08 prowler 650 will not start, took it out on the weekend and we rode HARD, on the last day i was pushing some bush and she just up and died on me,started and ran long enough to get it on the trailer but was running really rough and now has not started since. there is fuel at the carb, and good spark and is turning over as usual, does anyone have any ideas or insight on how to fix this? any insight would be appreciated.

Thanks

Chris
Is your buggy snorkelled? if not the depth of water you were in where those pics were taken would definitely cause you some issues! lol... mine is snorkelled and that would be pushing it with mine.. haha... sounds like you got water in your engine maybe.. how does your oil look? if not.. check your coil and plug wire.. I had an issue with my 09 where the plug wire would get pinched right around the coil on the frame. it would run in the rain all day and then just all of a sudden it would act up and not wanna run.. I'd suggest putting a new plug in it too.. and if you don't have it snorkelled.. start there for sure man.. its the way to go.. especially riding in the deep stuff like it appears you do.. cheers! hope this helps :D
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
oh ya no my bike is snorkeled, up where we play its pretty much mandatory, ill replace the plug and check the wire, when my bike shut off i had just rammed a tree to break some trail, im worried that maybe it caused the timing chain to skip so its out of time, that would make the most sense to me, either that or my cdi box decided that was a good time to crap out.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
a RZR??? haha thats funny, a RZR would never go anywhere i go, however my buddy didnt want to get his ass wet so it was close quarters. also an update on my bike, borrowed a CDI from a buddy and that didnt change anything, took carb off and fired some gas in the motor and she started, tells me i got a fuel issue im guessing, and suggestions where to start?
 

·
Registered
Joined
·
90 Posts
Welcome, fellow albertan, first thing I would do is a compression test, if that checks out then I would check every electrical connecter for corrosion. I had an issue with mine once where some water got into one of the connectors and it made the efi light come on, so I took them all apart and put some dielectric grease in them all and never had an issue since. A compression test is where to start though, it will tell if there is engine damage.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Ok heres where im at, tore it down and she was like half the cam out of time, so i set it back to where its supposed to be, put her all back together, and she fired right up......it idled for like 30 seconds and then i rev'd it up a little and it stalled, now no start again, tore it back down and once again its out like half the cam.......has anyone had to replace there chain do to stretching? doesnt seem like to hard of a job to replace, looks like i can do it all from the top, what about the tensioner....ever have to replace these? my bikes got like 4000 km on it so it may be time, seems to be a fair amount of play in the chain and it doesnt want to lay in the cam gear to well on the outer edges of the gear. anyone ever had to do this or experienced it?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #11
i was going to replace both at the same time, however the part im worried about is that the chain doesn't track around the cam gear properly
 

·
Registered
Joined
·
46 Posts
As from the view from the pics the gas tank and cap are fully submerged. I would drain all the gas and fill it back up. Its probly got water in it. my .02
 
1 - 13 of 13 Posts
Top