Arctic Cat Prowler Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Just purchased a 650 on ebay recently. Was using it for plowing in my yard and could smell hot oil. Sounded like it was revving up but didn't have a whole bunch of power. I bought a new belt and took the cover off to install and discovered oil under the cover. That explained the smell and the revving. Took it to a dealer to have a seal replaced. My question is this? Is that a common problem?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
Well it was 70 today. Pretty rough day to get through. I think it is 58 or 60 right now. Don't feel bad for us yet. Wait till summer when it is 110. LOL
That sounds nice there, we're expecting below zero the later part of the week. Are highs are in the teens. Have a nice evening. Thanks again
 

·
Registered
Joined
·
16 Posts
Discussion Starter #11
Just got it back from dealer. Seal behind wet clutch replaced with one piece seal. (old one was 2) 5 1/2hr labor bill for $70 in parts. Hopefully permanently cured that problem. Now I'm ready to go ice fishing, if ice is thick enough. (One utv already fill through, Husband pushed his daughter and wife out than drowned)
 

·
Registered
Joined
·
1,510 Posts
Now I'm ready to go ice fishing, if ice is thick enough. (One utv already fill through, Husband pushed his daughter and wife out than drowned)
That is terrible news....definately watch yourself out there.

Hopefully your ride is fixed so you can start to enjoy.
 
1 - 13 of 13 Posts
Top