Arctic Cat Prowler Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
hey guys new on here decided to join i have a few questions first is when i try an take off it takes a lil gas to get get goin then jumps hard is there anyways to get a smooth take off secondly when ur going and let out the throttle it back fires compleatly stock except 2" lift spacers an 28's any input or insight is greatly appreciated its a 08 700xtx
 

·
Registered
Joined
·
1,324 Posts
Sounds like you may have aftermarket springs in the wet clutch.

I did not realize mine was different until I drove others that did not have to rev to travel fwd.

Mine had EPI utility clutch kit installed.

As far as the pop that I don't know being efi and all.
May try to reset the throttle position sensor.
 

·
Registered
Joined
·
3,295 Posts
also a welcome from Idaho
 

·
Registered
Joined
·
2,681 Posts
Welcome,Turf saver rear diff?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
thanks for the welcomes guys ill look into the clutch ive nvr dun anything to it so idk on the throttle position sensor how do u reset it? and if they come with a surf saver diff then thats what it has
 

·
Premium Member
Joined
·
8,040 Posts
welcome sanroman sounds like its got a clutch kit thats how my 06 prowler is and it has a clutch kit /de3 06 prowler/bighorns epi looneytune duals cdi king shocks mikuni pumper trail armor doors diamond built bed cover coolflo windsheld articcat top/see ya de3
 
1 - 9 of 9 Posts
Top