Arctic Cat Prowler Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
I went to move my Prowler out of the garage and i had no reverse i but it in reverse and it didnt do anything high and low work fine but in reverse it hits the rev limiter but doesnt move is it just the belt slipping or something worse.
 

·
Registered
Joined
·
103 Posts
Sound like it not going into gear. What year is it. does it have the cable shift or the linkage. On my 09 the arm that mover the cable bent and it messed up where all the gears where rev was N and just pas N was H and just past H was L. I just had to straighten the arm and welded a support to it so i wouldnt happen again.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
its a 09 xtz. it seems to go in all my other gears r working it just seems like nuthing is catching in reverse
 

·
Registered
Joined
·
95 Posts
Its the cable, I had the same problem, I ended up stuck on a tight trail because I couldn't get mine to go into reverse, It was a pain but I some how finally got it into reverse went back to camp and adjusted it all the way out on the shifter side of the cable, I still have problems with it, and the dealer said its adjusted right (B.S.!) Its a pain to get to the other end of the cable but I'll hav to do it. The bad part is that if the cable stretchs any I'll lose reverse again.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #7
thanks needspeed ill check it out this weekend when i get a chance. i suppose arctic cat will want to sell me a whole new transmission instead of just a cable to.
 

·
Registered
Joined
·
103 Posts
Im dont know if the XTZ is the same, but on mine you can unhook the cable from the arm on the transmission, then you can move the arm with a set if pliers or vice grips. That way you can manually put it into revers and if its still not moving its something internal.
 
1 - 9 of 9 Posts
Top