Arctic Cat Prowler Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Recently installed oil pressure water temp and volt gauges on the prowler. With the weather finally being decent and everyone wanting a ride I got it up to operating temps. When the oil is warm at an idle the oil pressure is 0. As soon as it revs up the oil pressure goes up. At about 20 MPH it runs at around 35. Is this normal?

I am running rotella t6 oil and just changed the oil in February.

I probably overfilled it with oil a little, would this cause the low or zero pressure at idle?
 

·
Registered
Joined
·
2,681 Posts
Recently installed oil pressure water temp and volt gauges on the prowler. With the weather finally being decent and everyone wanting a ride I got it up to operating temps. When the oil is warm at an idle the oil pressure is 0. As soon as it revs up the oil pressure goes up. At about 20 MPH it runs at around 35. Is this normal?

I am running rotella t6 oil and just changed the oil in February.

I probably overfilled it with oil a little, would this cause the low or zero pressure at idle?
If you installed a Hi pressure oil pressure gauge 0to80 or 0to100 it is possible that it will show 0 at idle. Over filling engine oil wount decrease oil pressure but it does increase crankcase pressure.
 

·
Registered
Joined
·
1,489 Posts
I have the intellitronix gauges on mine. The oil pressure gauge only has two digits and will show 00 sometimes if you go over 99 psi. Mine usually will do that on start up only, but drops as it warms up. I don't recall mine being 00 at idle after it warms up, but I'm not watching it every second.
 

·
Premium Member
Joined
·
8,040 Posts
Recently installed oil pressure water temp and volt gauges on the prowler. With the weather finally being decent and everyone wanting a ride I got it up to operating temps. When the oil is warm at an idle the oil pressure is 0. As soon as it revs up the oil pressure goes up. At about 20 MPH it runs at around 35. Is this normal?

I am running rotella t6 oil and just changed the oil in February.

I probably overfilled it with oil a little, would this cause the low or zero pressure at idle?
I have a zero to 100 psi Auto meter gauge,when its cold it will go to 100 psi then drop down as it warms up,after it gets hot it will idle at 10 psi and at 25 mph it reads around 50 psi,I use 0/40 amsoil with a wix filter.I think may be a digital gauge might read a little different than a needle gauge.?????????not sure........
 

·
Administrator
Joined
·
7,232 Posts
Using 0/40 Synthetic on my Prowler shows 0 PSI at idle when fully warmed up. First start cold results in 50-60, after warm up it drops to 10 at idle, and 25-30 at 2500 RPM.
Back to the engine, my Prowler specs are 10-12 PSI at 2200 RPM. Roller bearing motors won't see a lot of Oil Pressure. Oil Flow is more important.
 

·
Premium Member
Joined
·
8,040 Posts
If you installed a Hi pressure oil pressure gauge 0to80 or 0to100 it is possible that it will show 0 at idle. Over filling engine oil wount decrease oil pressure but it does increase crankcase pressure.
I thought about that Joe,makes a lot of since on the gauge theory.:)
 

·
Administrator
Joined
·
7,232 Posts
I think your machine is normal, Not sure how much oil pressure the manual call's for on your 650, but 10-20 at 2200 RPM (Warmed Up) is what the factory uses as a test minimum. 650 Owners can help more.
 

·
Premium Member
Joined
·
8,040 Posts
I think your machine is normal, Not sure how much oil pressure the manual call's for on your 650, but 10-20 at 2200 RPM (Warmed Up) is what the factory uses as a test minimum. 650 Owners can help more.
RD mines probably real close to that,I will have to check that out.
 

·
Administrator
Joined
·
7,232 Posts
My 700 is tested at 10-12 PSI @ 2200 RPM
 

·
Premium Member
Joined
·
3,640 Posts
This is out of the manual for the 650. I'm taking my mother-in-law to the eye dr. this morning, when I get back I'll start mine and get some gauge readings from it.
Oil pressure lower hose.JPG Oil pressure upper hose.JPG
 

·
Administrator
Joined
·
7,232 Posts
I stand corrected! Someone on the forum always has the correct answer! Thanks!
 

·
Premium Member
Joined
·
3,640 Posts
I agree with what Joe said also about high pressure gauges, kind of like using a car tire gauge to check ATV tires, not as accurate as a low pressure gauge.
 

·
Premium Member
Joined
·
3,640 Posts
Oil

Oil pressure cold at idle
2014-04-02 10.37.16.jpg
Warm at idle
2014-04-02 10.52.25.jpg
Warm at 2,500 rpm
2014-04-02 10.53.05.jpg
 

·
Premium Member
Joined
·
3,640 Posts
Forgot to add my sending unit is on the return line from the oil cooler.
 

·
Administrator
Joined
·
7,232 Posts
Like your gage! The 700's are lower all around. Test at 10-12 @ 2200 rpm. Most I've seen on mine is 65-70, but that is first start up during the summer months when I run 20/50 synthetic. Also when I run 20/50 the oil pressure warning light does not flicker as when I run 10/40, or 0/40. Light is set at 6 PSI
 
1 - 20 of 22 Posts
Top