Arctic Cat Prowler Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey Everyone,
I am brand new to this site! Hoping someone out there can help me out! I have a 2007 Prowler 650 H1 XT. On Friday evening, a co-worker and I were coming back into town from out surveying - going through a lot of snow with it. We ran through the car wash to get the snow off the unit, and clean it up a bit before we dropped her in the garage for the weekend.
Now, over the weekend I had installed a snorkel kit on it, and when I went out for a test run, it is running really rough when you try to accelerate with it. Idels just fine. There is a slight burning smell once you have been trying to get her going. I noticed that smell on Friday night when I dropped her in the garage, but thought nothing of it at the time. Is it just a setting on the carb that may have got messed up when I was in the car wash? I did not notice it running rough on Friday night when I put her to bed due to unloading it off the trailer, and strait into the shed - did not have to get her to cruising speed at all for that!
Any ideas anyone? The snorkel kit should not have affected anything on the setting I would not think.
Just if anyone is wondering, we are in North Dakota, and the reason for the snorkel kit, is when we go surveying through all this snow, I kept sucking snow into the air filter and plugging it up and then it would start to run rough like that as well. We would get a lot of snow kicking up due to the set of tracks that we have on this unit.
Any help would be appreciated. I need to get this unit up and running for tomorrow for work again!
Thanks
KLJ4875
 

·
Registered
Joined
·
7 Posts
Sounds like classic water in the fuel to me. Unit will usually idle perfect but give her any kind of gas and she hesitates or stalls. Siphon and refuel. Just a thought. Good luck
 

·
Registered
Joined
·
3 Posts
Take the snorkel off and put it back to stock and see what happens.....i had to rejet when i put my snorkel on.....hope this helps
 

·
Registered
Joined
·
90 Posts
Sounds like water in the fuel, I would drain the fuel and replace and also drain out the carb, there is probably water in the bowl as well. Since you are in a colder climate, it wouldn't hurt to put in some gas line antifreeze in the tank to get rid of any other water trapped in the system.
 
1 - 4 of 4 Posts
Top