Arctic Cat Prowler Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
267 Posts
Discussion Starter #1
I have an 07 650 I have included pics... It will not with one person in it go over 35 no matter what? What do you need to know and I will answer to get some answers. I cant take it anymore I want speed back.Things I can tell you all stock except clutch spring, wheels, tires, cage, back seat, front seat. HELP!!!!!!!!!!!!!!!!!
 

Attachments

·
Registered
Joined
·
682 Posts
I think i would start with the clutch,spring.Whatever was done to the clutch, spring, weights, whichever, if it ran good before , it should run ok again. Thats a good place to start.
 

·
Registered
Joined
·
267 Posts
Discussion Starter #3
I think i would start with the clutch,spring.Whatever was done to the clutch, spring, weights, whichever, if it ran good before , it should run ok again. Thats a good place to start.

I think I would like to get back to stock... But with the addons I have will I be able to get above 40 with all stock stuff spring weights etc. would the belt have anything to do with it I havent replaced it. I also have noticed that it seems the motor is starving for air and backfires when I back off or floor it and the rev limiter hits I have a K&N Filter so I am thining it is getting good air???? I ahve so many questions I hope everyone is patient with me.

Oh yeah I have also just adjusted the valves so they should be good.
 

·
Registered
Joined
·
267 Posts
Discussion Starter #5
If your hitting the rev limiter and only going 35 then the clutch/belt is slipping. Your not getting the power to the ground. Mine stock clutch with 4 seater cage after market tires and wheels, does 52 mph at about i think 7k rpm
Thank you for the info do you know of any good shops to get some clutch work done?
 

·
Registered
Joined
·
271 Posts
you need to have some clutch work done and you need a new belt sounds like. the stock secondary spring with a 19-20 gram roller weight combo will do you well. possibly do the stage 1 machining to gain you some low end power to help get that heavy bike rolling, and your motor should pull you to 50+ with no problems.
 

·
Registered
Joined
·
463 Posts
Also make sure your K&N is clean Ive seen this problem on ATVs. Did a good shop adjust those valves? Did it run good before they were adjusted?
 

·
Registered
Joined
·
267 Posts
Discussion Starter #8
you need to have some clutch work done and you need a new belt sounds like. the stock secondary spring with a 19-20 gram roller weight combo will do you well. possibly do the stage 1 machining to gain you some low end power to help get that heavy bike rolling, and your motor should pull you to 50+ with no problems.

That sounds like a good plan... AIRDAM I just sent you a PM. Let me know
 

·
Registered
Joined
·
27 Posts
Newtothis,
I see exactly what your prob is. You need to get rid of those seats, rollbar and wheels, they are definitely slowing you down. This is not easy for me to say, but being the friend I am, I will gladly trade you my stock equipment so you can once again enjoy the speed. Seriously, they are all correct imho, once you take care of that, you'll be back in no time. Really nice ride by the way :)
 
1 - 9 of 9 Posts
Top