Arctic Cat Prowler Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter #1
so, ive been hearing some clicking in the rear of my 08 xtx lately. Tonight i jacked up the rear wheels and played around with it. in the forward and reverse gears, the tires spin fine. BUT when in gear, if i spin the drivers side wheel by hand, it locks up and tries to make the driveshaft spin, but when i spin the passenger side, it pretty much just spins freely. is this normal????
 

·
Registered
Joined
·
656 Posts
unless you have turf mode on your machine i don't think this is normal. sounds like the spool or whatever makes the rear end lock together is broken. I could be wrong, just an idea.
 

·
Registered
Joined
·
95 Posts
Discussion Starter #3
i didnt think it was normal. and nope, i dont have turf mode. is the diff rebuildable? or do i have to buy a whole new one??? It still drives good minus the click noise on take off. both rear wheels drive.
 

·
Registered
Joined
·
656 Posts
I could be wrong, but i think you have to replace the whole axle as one piece.
 

·
Registered
Joined
·
682 Posts
My 09 XTZ has been slipping when in a bind. i dont know if its the turf saver or what? thought i saw a thread about locking up rear end and doing away with turf saver.
 

·
Registered
Joined
·
95 Posts
Discussion Starter #10
I really only hear it when accelerating and stopping (with engine brake). I have an 08 xtx so i dont think i have the turf saver. like i said, both wheels seem to drive, but when jacked up and spun by hand, the passenger side seems to almost free wheel. i got some new diff oil so im going to try a flush this week (unless it rains all week like the weatherman says)
 
1 - 10 of 10 Posts
Top