Arctic Cat Prowler Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have an Arctic Cat Prowler 550 with only 450 miles on it. It dies and won't start. It has good, strong spark. 42 fp fuel rail pressure. There are no codes on the meter; however, it won't run to tell me the codes. I suspect the tilt sensor and if so, where is it located. I have a manual but it doesn't say where it is. Is there a good reputable after market parts dealer in the country?
 

·
Administrator
Joined
·
7,221 Posts
Welcome Mike, best site going! I have a 2009 700 XTX, the tilt sensor on mine is located under the passenger seat area. Have to remove the seats and doghouse to get to it. Mine is attached to the seat frame rail. Do you have a owners manual, parts manual, or a service manual? For the most part, I try to stick with factory parts. Country Cat, Babbitts, and several others offer decent pricing (don't laugh!). The Prowler is starting to be the redheaded stepson for aftermarket support. Let us know more about your machine, your location, and so on. Great to have you as a member!
 

·
Premium Member
Joined
·
3,640 Posts
Welcome to the forum Mike!
It seems someone else had a similar problem that turned out to be a bad starter pulling too much juice and not letting it start. I'm sure there's somebody here that can help you.

Hey RD watch that redhead stuff I used to be one :D:D it's all gray now!
 

·
Registered
Joined
·
432 Posts
I have an Arctic Cat Prowler 550 with only 450 miles on it. It dies and won't start. It has good, strong spark. 42 fp fuel rail pressure. There are no codes on the meter; however, it won't run to tell me the codes. I suspect the tilt sensor and if so, where is it located. I have a manual but it doesn't say where it is. Is there a good reputable after market parts dealer in the country?
How long since spark plug replaced? Some of us have had success just putting in a new plug when starting becomes problematic.
 

·
Registered
Joined
·
3,295 Posts
MM welcome to the house lots of info available here good to have you aboard

fill in your signature line and also location .. helps us answer a question without a question sometimes
 

·
Administrator
Joined
·
7,221 Posts
I got that problem too! Not Grey, Distinguished Looking! LOL
 

·
Premium Member
Joined
·
3,640 Posts
I got that problem too! Not Grey, Distinguished Looking! LOL
My wife tried to get me to color it once, I said no way after 2 wives and 2 daughters I earned that grey hair.:eek:
 

·
Registered
Joined
·
3,295 Posts

·
Administrator
Joined
·
7,221 Posts
That Too!!!!!!!!!!!!!!!!!!!!!!!!!!!!!LOL
 

·
Premium Member
Joined
·
8,040 Posts
I have an Arctic Cat Prowler 550 with only 450 miles on it. It dies and won't start. It has good, strong spark. 42 fp fuel rail pressure. There are no codes on the meter; however, it won't run to tell me the codes. I suspect the tilt sensor and if so, where is it located. I have a manual but it doesn't say where it is. Is there a good reputable after market parts dealer in the country?
Welcome to the best prowler site,wonder how much of an angle you have to have for the tilt sensor activates.
 

·
Registered
Joined
·
109 Posts
Replace the spark plug. I bet it will start then. I had the same problem with mine last summer. Dealer told me to replace the spark plug and it will start. I called bs. But I did it. And she fired right up.
 

·
Registered
Joined
·
733 Posts
Replace the spark plug. I bet it will start then. I had the same problem with mine last summer. Dealer told me to replace the spark plug and it will start. I called bs. But I did it. And she fired right up.
I second that! I had a 550 and a 700 prowler and it worked both times. mine would foul after winter storage.
 

·
Administrator
Joined
·
7,221 Posts
Hope it is that simple! Let us know!
 

·
Registered
Joined
·
7 Posts
I also am having the same issue. I have a 2009 artic cat 550 with 562 miles on it. I have good fuel pressure with a new spark plug. I have a EFI code on the screen though. It won't start by itself but if I put some starting fluid in it then it will start and then die. I am at a loss and have no clue what too look at next?
 

·
Administrator
Joined
·
7,221 Posts
Welcome to the site. Sure indicates fuel issues. Dis-connect all of the electrical plugs/connectors on your engine, clean them and apply dialectic grease to them then re-connect. You should have 43PSI of fuel pressure. Download a copy of a manual from K&T lawn equipment (Did I get it right Mike? LOL) The manual has a pretty good trouble shooting section, and a list of the trouble codes.
 

·
Administrator
Joined
·
7,221 Posts
Cool! Good Luck, Prowlers are awesome machines!
 

·
Premium Member
Joined
·
3,640 Posts
Welcome to the site. Sure indicates fuel issues. Dis-connect all of the electrical plugs/connectors on your engine, clean them and apply dialectic grease to them then re-connect. You should have 43PSI of fuel pressure. Download a copy of a manual from K&T lawn equipment (Did I get it right Mike? LOL) The manual has a pretty good trouble shooting section, and a list of the trouble codes.
LOL, that's the place and here's a link :D

"K&T Parts House Lawn Mower Parts and Chain Saw & Trimmer Parts"
 
1 - 18 of 18 Posts
Top