Arctic Cat Prowler Forums banner

1 - 20 of 47 Posts

·
Registered
Joined
·
140 Posts
Do you have to show those vids of your kid beating me? You really got that thing dialed in now. That RZR with no bed is in our group too. He is totally stock but it runs good. I think I blew a head gasket this weekend, so I wasn't running as strong as last time. Gotta take it in and see what's up.................
 

·
Registered
Joined
·
140 Posts
I was puking out anti-freeze sporatically this weekend and it heated up at random odd times. I had to fill it a few times with more coolant. Now it doesn't want to start up without giving it some gas. There is definately something wrong. And, I definately need paddles if I am gonna keep up with anyone. I can't get any traction. My buddy has the fastest stock RZR I have ever seen. He beats all other RZR's with that thing even the RZR-S. he just got a good one.
 

·
Registered
Joined
·
140 Posts
The oil looked fine, but it did in my 650 when the head gasket blew too. It could just be overheating badly for some reason. I don't know why the fan doesn't run with the key in the on position if the motor is hot. My 650 did, but this one doesn't do that. The fan is running though. The overheat idiot light only flahed twice during the weekend, but it puked out coolant about 5 times. Then it would run fine for ride, then it wouldn't. I don't really know for sure what is wrong. The fact that it won't just start right up now is disturbing too.....................
 

·
Registered
Joined
·
3,564 Posts
Discussion Starter #11
It was pretty cool outside this weekend too.I talked to another guy the weekend before that said his was running hot too.Mine was running cooler than normal this weekend.I got a feeling the gauge has died.I am still running the 650 radiator and fan.Every once in awhile on a warm day it will go into limp mode.Hopefully AC did not overlook the same things they did on the 650 head bolts-washers.The 1000 radiator is nice and big too.I was eyeballing it for my prowler.



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
 

·
Registered
Joined
·
338 Posts
I read somewhere that a guy was having a overheating issue on his 1000 and they discovered a pinhole leak in the head gasket.
 

·
Registered
Joined
·
682 Posts
I thought i saw one in the rooster tail you were leaving. bleep bleep, the XTZ's havnt been out 6 months and we are already getting our asses kicked lol
 

·
Registered
Joined
·
3,564 Posts
Discussion Starter #19
Sounds to me like they are not getting enough air through the radiator.The radiator looks like it is big enough.Also sounds like a good time for the after market radiator guys to make a buck.The one guy I talked to said his has not gotten hot till he took it to the dunes.I guess the extra load there is finding the weekness. t
Same thing happened to hapa's xtz, It spit coolant everywhee a couple of times and set off the overheat sensor.


Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
 

·
Premium Member
Joined
·
1,603 Posts
Called my Arctic Cat dealer and told him about the overheating issue. he is calling AC today to see if there are similar situations. Will keep you guys updated with what his response is.

Nice Video's Chris! you cat is fast!!!!!
 
1 - 20 of 47 Posts
Top