Arctic Cat Prowler Forums banner

1 - 20 of 52 Posts

·
Registered
Joined
·
2,681 Posts
Mine works
 

·
Registered
Joined
·
140 Posts
Mine works on the XTZ. On my 06 I had to adjust it a couple times, but that made it work just fine. They do stay in adjustment longer if you don't drive around with the parking brake on.........................
 

·
Registered
Joined
·
277 Posts
I had to replace the cable and adjust it properly, but it works well now.
 

·
Registered
Joined
·
67 Posts
I broke mine initially by leaving it on and driving (Doooh!) That just required a pad change. Then, my friend borrowed it and did the same thing. It also developed a siezed piston and stretched parking cable, so I replaced the parking cable and the entire brake assembly. Works fine now. Also replaced the rotor - around $50.
 

·
Registered
Joined
·
93 Posts
you all can trust them all you want, i know they ain't worth beans, and won't trust mine at all. the hydraulic lock thing is the first thing i will put on when i get back in Oct.
Steve
 

·
Registered
Joined
·
74 Posts
For the guys that have one that doesn't work, where are you guys adjusting it?
I tried to adjust the cable first but it still didn't hold. I then loosened the cable, moved the arm on the caliper one notch, then adjusted the cable so it worked good. Like I said earlier, no problems now. (and I never drove with it on ;) )
 

·
Registered
Joined
·
338 Posts
Sandchris has a hydraulic park lock that they use on buggies he says it works awesome. I pitched mine in the corner of the garage. My Rotax tranny has park.
 

·
Registered
Joined
·
4 Posts
Mine don't work at all. The arm on the caliber moves but the pads don't squeeze the rotor. Does anyone know what I can do to fix it?
 

·
Registered
Joined
·
1,324 Posts
The service manual has a good write up on adjusting.
You have to re-position the arm the manual gives the spec's clearly.
I adjusted mine per. the manual and works good now.
 
1 - 20 of 52 Posts
Top