Arctic Cat Prowler Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hey guys I got an 06 Prowler that does not want to start. I narrowed it down to being a fuel problem. I removed the line from the fuel pump that goes to the carb and poured some gas in it and she starts right up and runs until that little bit of fuel runs out. I also noticed there was no fuel spewing out of the pump when I did that. I bought a new pump and filter and installed em both. I removed the line that goes to the carb with the new pump installed and no fuel spewing from it either when im cranking the engine. Is it possible the new pump is bad too? The vacuum seems to be fine going to the pump and all the lines are clear. Should there be fuel coming from the pump while im cranking the engine? Any ideas? This is driving me nuts! It still starts and runs fine if I remove the line from the pump that goes to the carb and manually fill it with gas. Please help!
 

·
Registered
Joined
·
618 Posts
Isn't the pump on the 650 vacuum run?

If it's not drawing tthough you most likely have a vacuum leak somewhere.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
That's why I'm confused as I said before the vacuum is working fine. All the hoses are new and the intake boot is good too. Going to take the pump back and see if I can exchange it for another.
 

·
Registered
Joined
·
656 Posts
So you did try to crank it with everything hooked up so the vacuum could pull?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Thanks guys I'm a douche. I checked everything twice and finally got pissed and decided to change all the lines and start ordering a new intake boot just in case there was a vacuum leak somewhere. Well turns out when I originally checked the supply line I did it half assed and did not disconnect a small zip tie that was holding the supply line to the vent line. So when I cut the zip tie off I found it had rubbed a hole in the supply line. Gas flies out of the pump now with a new fuel line. Cat runs great again and I feel like a jackass. But a happy jackass. Thanks again for your help.
 

·
Registered
Joined
·
2,390 Posts
Thanks guys I'm a douche. I checked everything twice and finally got pissed and decided to change all the lines and start ordering a new intake boot just in case there was a vacuum leak somewhere. Well turns out when I originally checked the supply line I did it half assed and did not disconnect a small zip tie that was holding the supply line to the vent line. So when I cut the zip tie off I found it had rubbed a hole in the supply line. Gas flies out of the pump now with a new fuel line. Cat runs great again and I feel like a jackass. But a happy jackass. Thanks again for your help.

Trust me every on this forum has done something simular. Glad you were able to fix the problem.
 

·
Registered
Joined
·
656 Posts
No biggy dude. We've all been there. Promise you that. Glad you got it fixed and back on the trails!
 

·
Registered
Joined
·
3,564 Posts
Really don't feel that way. I bet this thread will help someone else out.
Thanks guys I'm a douche. I checked everything twice and finally got pissed and decided to change all the lines and start ordering a new intake boot just in case there was a vacuum leak somewhere. Well turns out when I originally checked the supply line I did it half assed and did not disconnect a small zip tie that was holding the supply line to the vent line. So when I cut the zip tie off I found it had rubbed a hole in the supply line. Gas flies out of the pump now with a new fuel line. Cat runs great again and I feel like a jackass. But a happy jackass. Thanks again for your help.


Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
 
1 - 11 of 11 Posts
Top