Arctic Cat Prowler Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
hi i have a 2011 xtz 1000 and the code keeps popping up on the display for the power steering. anyone have this problem. whats the fix? thanks.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Welcome to the site kingcatguy. That is a new one for me. I would think this early in the game with the power steering that the dealer might be your only option. But please post up what the problem and fix was so it may help someone else. Thanks
i am talking to my dealer and we are going to try a new regulator. this is what cat has told him. if this doesnt work cat is working on a new harness for the power steering. i will let everyone know what works to fix this problem.
 

·
Registered
Joined
·
1,324 Posts
any update?

Thrown the code 3 times in 12miles.

I am gonna call dealer in a little while and talk to the mechanic.
 

·
Registered
Joined
·
4 Posts
I have a 2011 a xtz 1000 with the power steering code po635 popping up first they told me it was from stopping to much they recoded it put a new one it replaced battery now it is on all the time I have less than 500 miles
 

·
Registered
Joined
·
95 Posts
Recontact the dealer and have them call cat for the latest EPS update. There's a tool that they have that installs their latest and greatest programming that will eliminate this code. The EPS system picks up info 1000 times per second and any fluctuation in voltage may trigger the P0635 code. The battery and voltage regulator are places to start. If that fails, get the new program installed.
This EPS motor is the same one that Polaris uses and Can-Am is also considering to use in their future models.
 

·
Registered
Joined
·
95 Posts
Recontact the dealer and have them call cat for the latest EPS update. There's a tool that they have that installs their latest and greatest programming that will eliminate this code. The EPS system picks up info 1000 times per second and any fluctuation in voltage may trigger the P0635 code. The battery and voltage regulator are places to start. If that fails, get the new program installed.
This EPS motor is the same one that Polaris uses and Can-Am is also considering to use in their future models.
 

·
Registered
Joined
·
4 Posts
I had it recoded two weeks ago and the code still is coming up and no power steering. They put a new gel battery in it I bought a new trickle charger and put it on over night it had 13.5 volt the code po635 came up no power steering. I called the dealer he said bring it .So today I start it up and no code i have power steering but I take it to the dealer they put it on the almighty code reader and it says there are no codes
 

·
Registered
Joined
·
3 Posts
I had this code on my machine and on a demo unit at the shop. I unplugged the two electrical connectors at the power steering unit, coated them with dielectric grease, and plugged them back in. The problem has not returned since on both units so far (300 miles on my unit). Also make sure the wire harness has some slack in it at that point. The wires come out of the connector upward and make a sharp downward curve where they are zip tied to the frame.
 

·
Registered
Joined
·
11 Posts
Good Call

I had this code on my machine and on a demo unit at the shop. I unplugged the two electrical connectors at the power steering unit, coated them with dielectric grease, and plugged them back in. The problem has not returned since on both units so far (300 miles on my unit). Also make sure the wire harness has some slack in it at that point. The wires come out of the connector upward and make a sharp downward curve where they are zip tied to the frame.

I found that only one of my connectors had dielectric grease in it from the factory. The one closest to the left front tire had some, the one on top of the unit did not.

I put some in both connections and the code seems to have gone away. I have used it maybe 4 times since with no codes, and it did pop up everytime I used the machine.

Thanks for the good advice.
 

·
Registered
Joined
·
4 Posts
I have done every thing that has been recemended and I still have the code poping up. The next thing I am going to try is putting second battery in sence I am not getting any help from arctic cat
 
1 - 19 of 19 Posts
Top